ceph common code (libceph) · Supported
Maintainers
- M Ilya Dryomov <idryomov@gmail.com>
- M Alex Markuze <amarkuze@redhat.com>
- M Viacheslav Dubeyko <slava@dubeyko.com>
Paths
- F
include/linux/ceph/ - F
include/linux/crush/ - F
net/ceph/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-block (capped at 30), ordered by date desc.
-
STALE445d
[RFC PATCH 33/35] ceph: Use netfslib [INCOMPLETE]
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 24/35] ceph: Make ceph_calc_file_object_mapping() return size as size_t
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 22/35] libceph, rbd: Convert ceph_osdc_notify() reply to ceph_databuf
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 21/35] libceph: Make notify code use ceph_databuf_enc_start/stop
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 20/35] libceph: Remove ceph_pagelist
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 18/35] libceph, rbd: Convert some page arrays to ceph_databuf
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 19/35] libceph, ceph: Convert users of ceph_pagelist to ceph_databuf
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 17/35] libceph, rbd: Use ceph_databuf encoding start/stop
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 15/35] libceph: Make osd_req_op_cls_init() use a ceph_databuf and map it
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 16/35] libceph: Convert req_page of ceph_osdc_call() to ceph_databuf
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 14/35] libceph: Remove bvec and bio data container types
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 13/35] rbd: Switch from using bvec_iter to iov_iter
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 12/35] libceph: Bypass the messenger-v1 Tx loop for databuf/iter data blobs
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 10/35] libceph: Convert notify_id_pages to a ceph_databuf
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 09/35] libceph: Remove osd_req_op_cls_response_data_pages()
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 08/35] libceph: Unexport osd_req_op_cls_request_data_pages()
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 07/35] libceph: Change ceph_osdc_call()'s reply to a ceph_databuf
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 05/35] libceph: Add functions to add ceph_databufs to requests
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 03/35] libceph: Add a new data container type, ceph_databuf
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE445d
[RFC PATCH 02/35] libceph: Rename alignment to offset
2025-03-13 · David Howells <dhowells@redhat.com> -
STALE484d
REVIEWED: 3 (3M) [PATCH v4 2/2] libceph: convert timeouts to secs_to_jiffies()
2025-03-01 · Easwar Hariharan <hidden> -
STALE466d
REVIEWED: 3 (3M) [PATCH v3 07/16] libceph: convert timeouts to secs_to_jiffies()
2025-02-25 · Easwar Hariharan <hidden> -
STALE511d
[PATCH v2 3/3] libceph: convert timeouts to secs_to_jiffies()
2025-02-03 · Easwar Hariharan <hidden> -
STALE502d
[PATCH 07/16] libceph: convert timeouts to secs_to_jiffies()
2025-01-28 · Easwar Hariharan <hidden> -
STALE712d
[PATCH v4 4/4] libceph: use sendpages_ok() instead of sendpage_ok()
2024-06-11 · Ofir Gal <hidden> -
STALE749d
[PATCH v3 4/4] libceph: use sendpages_ok() instead of sendpage_ok()
2024-06-06 · Ofir Gal <hidden> -
STALE754d
[PATCH v2 4/4] libceph: use sendpages_ok() instead of sendpage_ok()
2024-05-30 · Ofir Gal <hidden> -
STALE757d
[PATCH 4/4] libceph: use sendpages_ok() to instead of sendpage_ok()
2024-05-30 · Ofir Gal <hidden> -
STALE1051d
REVIEWED: 1 (0M) [PATCH AUTOSEL 5.15 29/31] rbd: harden get_lock_owner_info() a bit
2023-08-13 · Sasha Levin <sashal@kernel.org> -
STALE1052d
REVIEWED: 1 (0M) [PATCH AUTOSEL 6.1 43/47] rbd: harden get_lock_owner_info() a bit
2023-08-13 · Sasha Levin <sashal@kernel.org>